SuttaCentral

B. Sujato's Satipaṭṭhāna translation [EDIT: was] not loading

When I tried to load MN 10:

I just got undefined

iPhone 6s. Yes I cleared caches etc.

[EDIT: seems to be fixed?]

I don’t even get “undefined” on Chrome/Linux.

How will I ever get awakened if I can’t read this sutta? :disappointed_relieved:

3 Likes

Hmm, it has magically reappeared… :pray:

I am getting “Data Load Error”

It is working for me now.

Yes, some Suttas had this sort of issue, but it should be fixed now by @HongDa.

2 Likes

We pushed a major update to how the texts are marked up. This is intended to solve issues with display of root/translation. I inadvertently introduced bugs into a bunch of files. But I believe these are fixed now!

4 Likes

I’m still getting errors on android 10, latest version of chrome. I’ve cleared cache etc multiple times, but the errors still come up. Sometimes it’s “undefined”. Sometimes just a blank page. Sometimes a blank page with the navigation on top skipping out everything between Home and the Sutta (so it’ll say “Home > [the sutta]” instead of “Home > Discourses > etc > [the sutta]”). Sometimes I get “Data Load Error” with and without the sutta loading.

There doesn’t seem to be an obvious cause, and it doesn’t seem to be associated with a particular sutta. And the errors disappear on their own. But then they always reappear at some point.

Some screenshots I took today:



These things happen about 15-20% of the time I try to access a Sutta. Most of the time there’s no problem.

Arrg, sorry about your poor experience, I will alert our developers. But it’s really hard to debug something intermittent like this.

1 Like

I’ve seen this myself from time to time, too. It only seemed to happen with the Chinese Agamas, but that’s all I’ve been looking at. So at first I thought it had something to do with the Chinese texts, but I guess not.

1 Like

No worries, I just hope my feedback will be of some help. I appreciate how difficult it is to debug an issue that can’t be reproduced at request.

In case it’s helpful, I was having the same issues as @turntables (Android 11, latest version of Brave, clearing cache didn’t resolve the errors):

I did at one point get the following error message and then all the issues resolved shortly thereafter:

1 Like

I’ve gotten this too, a couple of times.

I’m pretty sure that is a cloudflair error. Cloudflair is a CDN and sometimes I guess it gets overloaded (although that’s the problem that a CDN is supposed to solve.)