Discussion for Bilara users

Apologies - this is likely a known and already discussed topic, but is it possible to work on Bilara via the Safari or Opera browsers? I can edit on Chrome without a problem, and can navigate to the the Bilara homepage on Safari, but when I actually go to a Sutta I’m translating, there is no text or translation option (see photo).

With Opera, I can’t even get to the Bilara home page (see photo).

As I can edit through Chrome, the issue is not so pressing, but if it was possible to edit through Opera or Safari, I would likely delete the Chrome app (and maybe Safari too if it worked on Opera). Thoughts?

Much gratitude for Bilara!

1 Like

Ajahn @kovilo Bilara is tested in Chrome only. Other browsers may work but aren’t tested. Cross-browser support seems to be getting better and a few translators use FireFox. Bhante has referred to this comparison in the past HTML5test - How well does your browser support HTML5?

1 Like

Yes, that’s right Carmi. We should definitely do more rigorous cross-browser testing. usually it’s only a few small things that cause problems—but you have to find those small things!

Thank you very much Bhante @sujato and @carmi for the message and note about Browser use! I will content myself with using Chrome :slight_smile: for now.
Bilara is the best!

4 Likes

Just to let y’all know, we are straightening out some data issues with Bilara right now. Probably nothing that will affect you, but I’d hold off publishing any texts right now.

3 Likes

Hi Bhante, just a headsup, I have reported in a separate and private conversation I am encountering some issues when I try to progress in the Portuguese translations. Not sure if you muted that thread but @carmi response is that I should raise my issues with you and see what are the next steps. Thanks in advance for your attention and reply. :anjal:

In our case, @Gabriel_L and I—Portuguese translators—review each other’s translations. We also have a spreadsheet to keep track of what has been translated and reviewed.

3 Likes

Good luck with your translations! :+1:
I doubt there is any Serbian translator on this forum.

Bonjour,

J’ai terminé la traduction préliminaire de SN 3.25 et je vous invite à la passer en revue et me transmettre vos commentaires. En vous remericant d’avance.


Hello,

I completed the preliminary translation of SN 3.25 and I invite you now to review it and share your comments. Thank you in advance.

Avec, with Metta
:pray:
Noé

2 Likes

Great to see you so actively translating!

Perhaps it would be worthwhile to post your progress in a separate thread? As I understand, this one is rather meant to discuss technical aspects or general questions regarding the use of Bilara.

2 Likes

Sure, this makes sense. I followed the guidelines on the Guide for translators > Requesting peer review which links to this thread. As you recommended, I will create a new thread. Thank you.

2 Likes

Hello,

I was prompted with this message after I published a translation.

422 {“message”: “Validation Failed”, “errors”: [{“resource”: “PullRequest”, “code”: “custom”, “message”: “No commits between published and translation_fr_noeismet_sutta_sn_sn3_sn3.3__translation-fr-noeismet”}], “documentation_url”: “Pulls - GitHub Docs”}

Is this normal? Did it go through?
Noé

1 Like

I can’t tell about the message, but no pull request by you has been created. You can see it in the bilara-data repository when clicking on “pull requests” in the top bar.

I think Bhante’s warning is still valid:

So as it seems, hopefully nothing has been messed up by your attempt.

Ouch, hopefully not. I had not seen this message from @sujato. My apologies, I’ll pay more attention in the future.

1 Like

I am trying it out now, to see if Publishing is back up. It should be okay, I’m just being cautious.

For those who have been struggling, I hear your pain!

It seems the underlying problem is that with the increase in users of Bilara, the Git system is finding it more difficult to resolve differences. We can all help by not over-stressing it, by which I mean, don’t publish too often, and don’t try to force things through if its not working.

Blake is working on it, and has some ideas, but the problem is that there are always corner cases and it’s hard to predict for all of them. Still, I’m sure we’ll figure it out.

Meanwhile, in good news for everyone, Blake has a demo of a proofreading feature for Bilara, it is looking good.

3 Likes

I can confirm that I just updated my translations, and they have pushed through successfully to sc-data (from where they will be served to the site).

Worth knowing that sometimes Bilara tells you that the update didn’t work, but actually it did. If you try to update and it says it didn’t work, don’t just smash the update button: pop over to the Bilara-data actions, that should tell you if anything is happening:

As you can see from there, the last run was my translations, which completed successfully.

(What the “Action” does is to assess whether the new update is formally correct, and move it into the “published” branch. Then we see a Pull Request in Bilara-data. We accept that, and another Action transforms markdown into HTML, and sends the final file to the suttacentral/sc-data repo. That forms the actual data store for SC.)

Alternatively, of course, just reach out to us here if there are any problems.

2 Likes

Hi @blake , bhante @sujato,

This is the error message when I try to publish an3.2__translation-pt-laera-quaresma :
image

And this is the error I get when I try to update an3.3__translation-pt-laera-quaresma :anjal:
image

Any idea of what I may be getting or doing wrong here?

:anjal:

1 Like

The guideline has been to publish once a week—is that still valid?

I always get error messages when publishing AN texts, but the pull requests are created nevertheless. Just check it out, as Bhante has explained above. If they aren’t, … hmm … in that case, probably @carmi has to have a look.

This has been an ongoing issue for @Gabriel_L and @ngvitor’s project. I think the next best step would be to work through with Bhante @sujato and @blake over a jitsi call. I’m not sure why Ayya Sabbamitta’s errors allow the pull requests to come through to GitHub while we don’t get to this step for the Portuguese project. It only occurs in AN as far as we know.

3 Likes

Hi,

I tried again to publish SN 3.3 and I was prompted with the same error message as @Gabriel_L. And no Pull Request was created.

Noé

2 Likes