Help needed from Apple users

I’m doing some testing on Apple iPad and Mac but need some help. Apparently there is a font-issue with the Burmese texts so I want to find out how far this issue goes i.e. if it is only the older iOS or also the newer ones.
So if you own an Apple Mac or iPad, please have a look at this page and then get back to me, mentioning your system type and iOS version:

The first lines should look like this:

However, I found that on the iPad with iOS 5.1.1. it looks like this:

Especially where there is a “box” around a character, it is moved to the next character in the line, changing the meaning of the words completely. Also other diacritical signs do not show correctly.

Thanks for your help!



I use a Mac with a OS X 10.10 Yosemite operating system.

When I view the sutta it looks like this:

Thanks @Brenna. That looks fine. I have the feeling the problem is more with the iPad than with the Mac.

I’m using an iPhone 5s, iOS 10. It looks like it’s rendering it correctly to me.

If you do find errors, you can actually file a bug report with Apple and they’ll eventually get around to fixing it.

Thanks @dancarter! It looks like the issue is (nearly) fixed in iOS 10.
@Aranya tested it on an iPad with iOS9 and the bug still showed. Apple adviced to install another font, which she did but that did not make any difference (which I did not expect anyway because SC uses it’s own fonts and does not rely on the device’s installed fonts).

However, I see that there are a few new issues with the Burmese font in iOS 10. Firstly, the bottom diacritical mark in the header is slightly offset, but this is not a real problem as it is still readable. But in the first line you see a dotted circle with a “tail” underneath. This should be part of the previous character.
Interestingly, Safari on Mac does not show this problem.

@Aranya and @dancarter, would you both be able to check if you can download Firefox and/or Chrome on your ipad/iphone and see how that looks? Maybe also check the reader in both Safari and Firefox.

I checked this on Chrome on the latest Android phone and there it worked well. Also Silk on Kindle seems to work well.

Burmese font rendering is complex and unstable, so hopefully this will work out.

Our font suppliers Rosetta have pretty much stopped development of their Burmese font, so I’m not sure if this will ever be ready for us.

Meanwhile, however, if we find a bug in the Noto Sans Myanmar we can file it here (if it’s not there already). (there is mention of a next gen version of this, not ready yet …)

I’m not sure what happened, but the offset of those diacritical marks seems to have been fixed.

Here’s the normal rendering in each browser:

And here’s reader view:


Thanks! It looks like that the Reader View is still not entirely correct, but the normal view on all browsers is fine.

@Aranya tried it on Chrome on iOS9 and that still showed the same problems.

I will file the bug on github as @sujato suggested.

1 Like

Hi @dancarter. I had word back from Google.
Can you send me a screenshot of the whole page on Reader rather than just the top? So I can pick up more samples of where it goes wrong.

Safari reader:

Firefox reader: