Linking Sutta Discussions from DhammaWheel.com

This is all fine. Don’t worry about the linking back, we’ll fix this as we go. @blake is still tweaking the code, it will take a little while to get right.

OK, it looks like SN12.15 has linked back, but MN19 still has not. I’m sure it will work out in the end…

Yes, this problem seems to have been fixed. It might still take a little while for the post to be indexed and picked up for SC, but it will get there.

Great news! I’m working through the process. I think the format is OK, and it’s not too difficult. I’m using the Pali titles from SC and the title of the SC English translation, if available.

OK, I have now put in links the suttas that we discussed over on Dhamma Wheel following Bhikkhu Bodhi’s lecture series:
A Systematic Study of the Majjhima Nikaya
http://dhammawheel.com/viewtopic.php?f=25&t=19951

Next there is much of the Sutta Nipata, then thematic series from the SN and the AN, based, again on Bhikkhu Bodhi’s suggestions:
SN: http://dhammawheel.com/viewtopic.php?f=25&t=345#p88300
AN: http://dhammawheel.com/viewtopic.php?f=25&t=19931
These have been alternating and are also interspersed with other bits and pieces.

It will take a while do do all that, but I’ve now got a procedure that is reasonably simple and quick.

It’s interesting to see these old discussions, and I’m pleased to have a way of indexing them to the suttas.

1 Like

OK, I’m up to the SN/AN part. It’s really interesting for me to revisit these discussions from several years ago. There’s so much interesting detail once one starts analysing suttas such as the following, and it’s great that the link from the Sutta Central post to the sutta itself, and to a parallel, are so seamless.

1 Like

It appears that the indexing hasn’t worked for the past few days. If it’s being worked on, that’s fine, good things take time! But I thought I should point this out, in case something is broken.

I’m getting even the last ones you have posted, so it seems to work for me. What exactly is not happening?

Hmm, strange. Here’s four examples. Am I looking in the wrong place?





Wheras this one links back fine:

Again, I am not clear what the problem is. All these look fine to me. And I am even getting results from this thread itself!

Can you specify exactly what you are looking at and what you are not seeing.

OK, I go to:


click on the three bars (what’s that called?),
click on Discuss and Discover
and see nothing.

this is on Firefox ESR 38.0 on Linux

There’s other things that are odd…
I then tried Chrome Version 42.0.2311.152 (64-bit) on Linux
and I don’t get the three bars!

So I went to my Window7 virtual machine.
Neither Firefox nor Chrome nor IE display properly. It’s just a vertical list of stuff…

The three bars? “Menu icon” AKA “Hamburger”. Perhaps we should use “Tofu burger”?

I can confirm that I’m not seeing anything on SN 35.246.

Not getting the menu at all on Chrome is bad, @blake can you investigate this. Normally we use Chrome for development so it is the last thing we expect to find problems with.

As for Windows 7 VM, hard to say, if we get confirmation that this happens on actual Windows 7 it might be worth looking into.

OK, it’s failing on a real Windows7 machine in both Firefox 38 and Chrome 42 (i.e. the latest updates).

OK, to be clear the menus are working fine in Discourse on my Linux Chrome. It’s on Sutta Central that they are not working.

Thanks, we are looking into these bugs.

It seems that the total failure of the format on Chrome is only on the first page, ie.
http://suttacentral.net
on
http://suttacentral.net/su
it displays correctly.

The formatting is now fine on all the browsers I mentioned above.

However, the linking still isn’t working for a number of the posts I mentioned above. Strangely, this thread appears for DN31 and MN113…

Excellent, that’s something!

Again, I just counsel patience. @blake is aware of the issues, and they will sort themselves out.

Thanks. A good chance for development of khanti.