SuttaCentral

Report bugs for the new site here! 🐛


#134

This is a red herring. Actually the Roboto specs are only there because they’re referred to in some element we use, but we ourselves don’t use them. So they should be blocked (in fact I specified that they must be blocked, as there are some reports that Google fonts get blocked on the way into China).

In the future we’ll get sneakier in eliminating such unnecessary code. :female_detective:

The fonts on the site itself are Skolar for Roman and Devenagiri, and Noto for other scripts.

Better to navigate vagga by vagga, or samyutta by samyutta. As Ayya Vimala points out below, we’ve disabled the ability to load the whole samyutta (and other collections of similar length) because it’s just silly!

These are valid points. We have tried to optimize the view for new or casual readers, so we put the translated title, description, and links for translations prominently, and make the information less dense and intimidating.

But this means some of the technical info, particularly IDs, is less prominent, and things take up more space. If you peruse some of the old threads on D&D where we discussed and evolved the ideas for the new design, you’ll see that various approaches to this were tried.

For a long time, in fact, I had in mind to implement a “compact view” or “expert view” to complement what we might call the default “reader’s view”. As time went on, though, this idea dropped away. It would need to be carefully thought through, but perhaps we should re-introduce it. We won’t do anything on this right away, but I have noted it on a list of possible UI improvements.


#135

In the meantime is there a manual way to do that? I can copy from the text info and create a link like this:
SuttaCentral
to highlight one paragraph. Is there a syntax for hightlighting multiple paragraphs, or is that not decided yet?


#136

Yes, that’s what you can do. For multiple ones use a syntax like:

https://suttacentral.net/mn1/en/sujato#sc2--sc6
(note the double dash).
You can also do it like:
https://suttacentral.net/mn1/en/sujato#2--6


#137

Brilliant, thanks.
Edit: I initially thought the second version didn’t work, but I think I mistyped something.


#138

I apologise for saying I was on an iPhone 5s. It appears that it’s an iphone 5.

I understand it’s not supported but the "your browser is not supported’ screen is not displaying either. If plug my phone into my computer and use the developer inspector I can see that it’s detecting that I have an older browser and trying to server the alternative content but what displays is just a white screen which take a long time to load.

I’m trying to find a newer phone from somewhere so that I can use SC with the new translations.


#139

First of all, please wait until we roll out the new upgrade for Safari and then see.

In the mean time, you can just scroll to legacy.suttacentral.net and see the old site instead.


#140

I was excited to see a new build, but unfortunately the same thing occurs on ios10.3 safari/chrome.


#141

Arrgh! We have tested it back to Safari 9, so this is disappointing. Can I ask you to try clearing your cache?


#142

I did indeed clear my cache.

Here is the error log

The version of iOS Safari I am using is being described as the following via Safari desktop’s developer tools.

User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1


#143

Oh dear! Maybe there’s a regression or variation in Safari versions. But the log report is great, our devas will be all over this.


#144

I’m more than happy to keep spitting out logs and anything else the tech-devas might need. I will be online easily until around the end of the month.


#145

Cheers, thanks so much. May I ask, why is Mozilla mentioned in the browser version? I see a similar thing, and have never understood it. My Chrome says:

 Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/64.0.3282.167 Chrome/64.0.3282.167 Safari/537.36

Also, maybe you could try staging.suttacentral.net, see how that is for you.


#146

Bhante, I honestly don’t know.

It’s also interesting that I’ve actually got a newer version of Webkit than you.

I have the same 82 errors on the staging site too.

EDIT
@sujato This might be the answer


#147

On my iOS-device, I can now see a little more diacritics with Safari, but not all.
On my macOS machine, I am unable to load the front page or a sutta with Safari, I only get a blank page. It worked quite nice before the recent update.

iOS 11.2.6 (cache cleared)
macOS 10.13.3, Safari 11.0.3 (cache cleared)


#148

Interesting.
I’m on MacOS 10.12.6 (Sierra) with Safari 11.0.3 and the site is doing fine for me.
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6

The only error I’m seeing is:

[Error] Refused to load https://fonts.googleapis.com/css?family=Roboto+Mono:400,700|Roboto:400,300,300italic,400italic,500,500italic,700,700italic because it does not appear in the style-src directive of the Content Security Policy.


#149

Might be a problem with high sierra then?


#150

Do you have Chrome on your mac?
I’d be interested to see if it worked in Chrome in High Sierra


#151

Both Chrome and Firefox are working fine - and show the diacritics right.


#152

I also cleared the cache and still no go on 10.1.2

I jsut tried to delete this post (seeing the discussion was about high sierra, not yosemeti) but don’t seem to be able to, can edit but not delete which was possible before. Am I doing something wrong?


#153

Oouuaaahhh… !!!

Today I tried for the first time to open the new SuttaCentral website on my Android tablet. And what did I find?—A completely blank page!

So this shows that SuttaCentral is the most Buddhist website ever: It takes you to the very perception of EMPTYNESS!!! :sweat_smile:

Android version 5.0.2