SuttaCentral

Report bugs for the new site here! 🐛

But, what about shipping? :yum:

2 Likes

I have now found what maybe (?) happened for me on the sutta page I was originally talking about. No little ‘v’ to access Pāli etc. that I can see.

1 Like

When not logged in, the top bar inhibits reading.

Oh, I just discovered that the column entitled ‘more’ has the Pāli in it, if you click the item underneath, and then click the same item once more. Could it perhaps be more helpful to bring that in line with the theme of the left hand column (‘translations’) and have this one called ‘Pāli’, as it is on the pages that have the ‘v’ dropdown menu, as the lefthand column there; or, ‘original text’ or something, if it is meant to be used for not only Pāli? ‘More’ seems a bit obscure and not immediately obvious what it is about.

2 Likes

Our developer is working on it. We discussed it this morning and he himself has a Mac with Safari and an iPhone with iOS. He has some ideas to fix it.

1 Like

Yes, we are aware of this bug. We are working on it to fix it asap.

:smiley:

I’ve seen this bug before, on Firefox, but it seems to have been solved there. Will report it back to the developers. Thanks for letting us know. It might be better if you move slowly over the text but of course, this has to be fixed.

That is a really bizarre bug. I can see the diacriticals well on Chrome on Ubuntu. I will refer to the developers but not sure what can be done about that.

Yes, we noticed and have it on the to-do list. You can still read all the posts but it’s annoying.

2 Likes

Congratulations, you win the prize for the most weirdly specific bug! Here, have some pancakes :pancakes:

Just to confirm, does this happen with Pali or similar texts on the old site or anywhere else?

5 Likes

One of our monks has tried to download the off-line version of SuttaCentral. On the download page it says the download is 28.28 MB, yet after using up over 2 GB the download was still only 50% complete. He had to abort. Do we know what’s going on?

4 Likes

We discussed this this morning with the dev-team. We are aware of the problem and are working on it.

3 Likes
  1. Chinese script falls outside of the popup definitions, in chrome.

  2. Chinese words that are broken by a line do not get their definition.

Screenshot shows both.

The second problem is because the HTML is splitting the words. In this case, the line is:

生處、廣<a class="t" id="t0421a25"></a>解、未曾有法及說義,

The first will be easier to fix than the second; the second will require automation on the data or a patient individual with a lot of time to try to identify and mark these issues.

102

Bhante, I am happy to volunteer to write code to help alleviate this problem in Chinese sutras, as my expertise is in data cleansing of this nature.

The solution I propose is to find all of these kinds of breaks, and take a best guess at moving them.

Ex:

生處、廣<a class="t" id="t0421a25"></a>解、未曾有法及說義,
                                                 \/
生處、廣解、<a class="t" id="t0421a25"></a>未曾有法及說義,

This will keep whole words together, and allow the dictionary to pick them up. I can simply make a Pull Request to the sc-data repository, with whatever changes I make.

Please let me know if this is something I can help with.

3 Likes

The number of AN3.48 is incorrect in the heading:

1 Like

Thanks so much we will look into this.

You are right, the underlying problem with the popup is the mixing of metadata with text. The best solution to this is to use “standoff properties”, where the text and markup are kept entirely separate. But this is not yet a mature technology, although we look to it with interest.

If you were interested to help with this, we would be more than delighted. At the moment we are pretty much inundated with getting things fixed! Maybe could you get back in touch with us in a few weeks? After things have settled down, you could maybe join our developers for a discussion, and see about getting a more refined approach to this specific issue.

Oops! Thanks, I’ve fixed it now, it’ll take a little time to show up.

3 Likes

Thanks for the pancakes, perfect for breakfast :slight_smile:

With the legacy.suttacentral or elsewhere, there is no problem with pali script. However, with iOS and Safari, I see the same behaviour. I installed Firefox for iOS and it omits fewer diacritics than Safari. With Firefox for macOS, the pali look fine.

Evaṃ me sutaṃ— ekaṃ samayaṃ bhagavā sāvatthiyaṃ viharati

This quote is just a test - I copied it from the MN118. I noticed that the behaviour of the Pali​ script changed a bit since yesterday, as it shows a bit more diacritics. The copied part above shows all - but just here on D&D.

1 Like

Hi, even if I didn’t find much time so far to explore it in full I love the new SuttaCentral!

Two things I noticed that may belong to this thread:

  • When clicking on a sutta link in D&D like MN 2 for example the underline just disappears on clicking, and that’s it. No link to the respective sutta.
  • When on the main page, scrolling down the homepage to “What’s new in 2018” this button leads me to the actual article about what’s new in 2018. When instead clicking on “What’s new” in the menu bar at the top of the page it redirects me to D&D in a new tab (https://discourse.suttacentral.net/c/meta/updates).

Using Chrome on Ubuntu.

One more thing: It seems to take ‘ages’ for edits to show up in my post!

Another one: After clicking the “i” at the top of a sutta and reading the information about the translator, on closing that little window I get this interesting image:

After a while it disappears again.

Actually, it disappears after I have switched to another tab in my browser (like D&D here, in order to type this post), and then go back to the tab with the sutta.

And one more surprise: When scrolling a bit further down the page I still find this (another sutta this time):

To make it more fun: When scrolling up and down the page the different bits are each time changing places… :sweat_smile:



3 Likes

It doesn’t work for me. Yesterday (or was it the day before?) it worked for less than a minute, but all the popups stayed open so it was a total mess, then I reloaded the page and it never worked since, doesn’t show anything. Mac OS 10.12.6 with Firefox. Here is the settings page:

2 Likes

I have seen the problem with diacritics and umlauts in the german translations, too. Again, Firefox is fine, but Safari has a problem with the text rendering, I think. Copy and past of the text reveal, that the information is there:

Some diacritics are shown, others not. The text is rendered properly with deactivated styles (developer mode - safari).

3 Likes

Is it correct that the choice for language settings to browse the site is just English or Polish? I don’t find anything else.

1 Like

I’m having similar issues with Chrome on Ubuntu. Happens some on D&D too for me. Could be an issue with the css in the Material Design theme? When I change themes in D&D it goes away. :heart:

2 Likes

It’s obviously not happening always.

Only now when you’re mentioning it did I look into the settings for themes on D&D. I still had Legacy, now trying Material Design. So in my case it cannot have to do with Material Design theme. :orange_heart:

2 Likes