SuttaCentral: bug reports

Therer’s a different error now. Donating and then clikcing the link below now returns me to:
https://suttacentral.net/search?lang=hu

0 search:resultsFor undefined search:inSelectedLanguage

Yes, it seems to be fixed now. Thank you for coming back to these and checking all these old issues! :pray:

The Pali test in general is much smaller overall, sutta or vinaya, and I always thought this is by design.

But in fact it seems to be rather a Firefox thing, for on Chrome it looks like this:

Still a bit smaller, but not so much.

However I got stuck when I saw a Pali word within the English part of the text, and this too was so small; this is where I thought it must be a bug. But in order to check how this is now I would have to scroll through many rules, because I don’t know exactly where such a case occurs.

But if none of the developers has done anything about it, it should still be as I found it.

1 Like

I’m using Firefox (122.0) and inline Pali looks perfect. That’s why I asked.

Search! Search! We’ve got a search feature! If you search for sheepskins, goatskins Then you get a single result. (sorry, I should have shared this in the first place) :Kd5.13.13.5


Thanks so much for testing! It appears that Hong Da has this working now on our staging site. You can try if you like: https://staging.suttacentral.net/donation-success

By the way, I noticed the hu in your link. If you speak Magyar, we’re looking for someone who can translate parts of the website interface. Please send me a DM (click on my profile icon and then click “Message”) if you are interested or know someone who might like to help.

2 Likes

For me it’s this:

And that was probably the place where I originally saw it.

1 Like

I should add: I also have the latest FF version installed, but it’s on a different operating system. I am on Ubuntu, you are on Windows probably.

1 Like

Not sure if this has already been flagged - the downloads page is empty. Tried it in several browsers, same result.

2 Likes

Yes,

There is in fact no more download page. The problem is that it redirects to a blank page.

If you need downloads, they can all be found on the editions page. The previously available IB Horner Vinaya translation is available on Archive.org.

2 Likes

Bhante Sujato’s English translation link is missing en/sujato:

https://suttacentral.net/mn9?view=normal&lang=en

The other translator links are correct.

I’m on Mac Sonoma 14.3

Thanks :pray:t3:

Where do you see this link? It is a link to a suttaplex card, and these don’t have language and translator specification. The suttaplex card gives an overview of what is available for a specific text.

The suttaplex card link is the same as Bhante’s. I.e., Bhante didn’t get a Bhante-specific link for his translation.

1 Like

I can confirm, @BethL, That the link to Bhante Sujato’s translation is indeed there on the SuttaPlex card, but when you click on it you are redirected back to the suttaplex card.

Even typing in the complete proper link to Bhante’s translation doesn’t work. Just takes you to the suttaplex card.

The bilara file is there. @HongDa ?

2 Likes

Ah! It wasn’t clear to me that you are talking of the links on the suttaplex card itself. Oh!

And even more strange: When language is set to DE on SuttaCentral, the sujato link is working just fine! But on my machine too, it isn’t working when lang=en. The URL line shows mn9/en/sujato for a very short moment, then removes en/sujato and goes back to the suttaplex card. A circle link, so to speak.

And the file is in fact in the repository as expected.

This is indeed a case for @HongDa. Thanks for discovering it, @BethL. Have you seen that anywhere else?

2 Likes

Venerable I haven’t but, that said, I haven’t been looking for it. If I were troubleshooting I’d be curious how these links were originally generated and whether any regression testing is conducted after new releases. Or whether we’re relying solely on user errors reported. Easier said than done.

2 Likes

Galaxy Tab S8
Model SM-X700
Android v14
Google App and Chrome browser

Suttas show up in a list format that does not mirror what is in production on iphone, mac ios, and pc.

Here’s the step-by-step:

  1. click on pāli app icon or go to suttacentral.net (either way)
  2. land on navigation screen (renders correctly)
  3. click on Basket of Discourses link
  4. land on Suttapiṭaka screen with the list of Collections (renders correctly)
  5. click on any collection (doesn’t matter; let’s say DN)
  6. land on Digha screen (renders correctly)
  7. click on Long Discourses Collection
  8. land on Dighanikāya screen (renders correctly)
  9. click on any of them (let’s say The Great Chapter)
  10. land on Mahāvagga – does not render correctly as it looks like the attached screen shot. Versus what shows up correctly at this stage on, e.g., mac ios for comparison.

When I click on any of the horizontal sutta IDs (see sceeenshot), I go to the normal display of the pāli translation of whichever sutta is identified in the far left column of the screen shot (in this case, any of the far left references go to DN 14 ). At that point, everything is back to normal – parallel views work, e.g.

So the bug is at Step #10.

This has been happening for several months; it used to work.

I can’t understand from your description what you are doing and what is happening. Your top image is of DN and the bottom image is from Dhp.

Can you go step by step what you are doing on the tablet and then step by step on the desktop? I’m not sure what is going wrong on the tablet or how you got to the photograph of the screen. Try and describe each image as it happens.

Also, include the browser name for the tablet.

1 Like

Extremely bottom-of-pile trivial & unimportant =)

I only see this on a laptop:
Lubuntu 22.04, both Brave Version 1.63.161 and Firefox 123.0
It looks fine on a phone:
Samsung Galaxy S7 edge, Android 8.0.02 Brave 1.62.162

When viewing comments as tooltips, sometimes there’s a period after the tooltip asterisk:
screenshot-dba37c52
Examples of this are after segments pli-tv-bi-vb-pc34:2.1.14, mn39:14.1, pli-tv-pvr7:63.8

1 Like

Hi, @BethL Are you referring to this link?

Yes. This is what I’m referring to.

Thanks :pray:

Currently, Bhante Sujato’s translation can be opened normally in Chrome and Firefox on my local computer. Does the same error occur in the privacy mode of the browser?

Thanks, HongDa. Did you review the specs I provided in my original post?