SuttaCentral

Android issues - no preview etc

Some changes from a recent upgrade are making it harder to use D&D on my Android Moto cellphone. Some problems may be due to my use of a larger font.

  • Creating a new topic - see screenshots for the difficulties working around the heading and inf boxes to create this new topic. (And can’t always click off the “similar topic” box b/c can’t reach the x in upper corner)

  • Format on opening D&D - my icon on the far right is no longer visible. I know to scroll right to find it but a new user wouldn’t know that.

  • Preview function stopped working. See screenshots of hide preview & show preview (they’re nearly identical). Normally I use this function a lot to double-check my posts.

If there’s a fix I can do to use preview, plz let me know. Thanks!

I’ve just checked this on my mobile and I cannot reproduce any of your issues.

How did you set larger font, via browser settings, Android settings or Discourse settings—Text Size? I tried Larger and Largest and both work fine. Do the issues persist if you return the font size to normal?

You might also try:

  • hard refreshing the page (open forum in browser, paste javascript:location.reload(true) to address bar, press enter)
  • clearing app cache for your browser and reopening the page
  • restarting the phone (possible memory issues)

If this doesn’t help please write down your

  • screen resolution
  • Android version
  • browser / version you are using

and I’ll investigate further.

3 Likes

Hi @musiko, thank you so much for exploring this problem with me. It’s solved now but has created a new mystery. Here’s my process:

  • I didn’t bother with the cache since I remove caches frequently, to make more room on my phone (too many photos taking up all the memory).

  • Just now I restarted the phone, without affecting the problem.

  • Next I reduced the size of font on my cellphone, without affecting the problem.

  • Then I also reduced the size of font on D&D - and with both fonts reduced, success! All the problems vanished.

Thanks for your suggestions! Even though I suspected fonts, I didn’t remember having adjusted them on D&D (and had a dickens of a time finding that option - it’s under Interface within Account not under Preferences 🤦). I also was unclear where to find the setting on my phone. It was only with your encouragement that I went digging and found the solution.

But here’s the mystery now. I went back and enlarged the fonts both on my phone and on D&D, yet the problems did not recur. So it’s a bug rather than a feature? :thinking:

Any thoughts? I’m pleased but a bit baffled.

1 Like

Computers are a mystery! There is such a pile of bugs upon hacks upon workarounds, it’s astonishing that anything works ever.

4 Likes