Enable https for Discourse

@blake, i was surprised to see that Discourse doesn’t enable https be default. There’s a setting for it here, but it says we have to have https set up and working. Can you do the necessary? Ta.

Okay https has been enabled. This involved:

  1. Creating a pagerule on cloudflare for discourse.suttacentral.net, and having it use ‘flexible SSL’.
  2. To fix mixed content warnings/errors, replacing all http:// links to fonts, with the ‘//’ form (match scheme).

I also set the checkbox, but I’m not convinced it has done anything.

Thanks; I’m not seeing the s, perhaps its a cache thing.

I don’t know why it didn’t work with the checkbox, but I’ve set Cloudflare to do the redirect. Discourse is now HTTPs only. Current browser sessions will probably break until the user refreshes the page.

Good, yes, it’s all https goodness for me now.

By the way moving to https has broken the plugin (mixed content warning) so I’ll need to update the plugin. Since updating the plugin is invariably painful I’ll fix some bugs and integrate the tagging tags while I’m at it.

1 Like