Error after following "Developer Setup Guide"

Hey folks,

While I’m not planning to hack SC in the near future, I thought I’d try getting it up and running on my Infrabook (opposite of an Ultrabook - 2008 model Dell Vostro 1500 with a Core 2 Duo CPU and 4GB of RAM).

I started here: Developer Setup Guide

When I get to running the server with invoke server I get the following output:

Building Text Image Index
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/home/jhanarato/.pyenv/versions/3.5.0/lib/python3.5/", line 923, in _bootstrap_inner
  File "/home/jhanarato/.pyenv/versions/3.5.0/lib/python3.5/", line 871, in run
    self._target(*self._args, **self._kwargs)
  File "/home/jhanarato/suttacentral/sc/", line 208, in inner
  File "/home/jhanarato/suttacentral/sc/", line 63, in init
  File "/home/jhanarato/suttacentral/sc/", line 21, in build
    index = create_index_and_update_symlinks()
  File "/home/jhanarato/suttacentral/sc/", line 32, in create_index_and_update_symlinks
    symlink_md5 = sc.util.get_folder_shallow_md5(folder=sc.text_image_symlink_dir, check_mtime=False, include_filter=image_filter)
  File "/home/jhanarato/suttacentral/sc/", line 277, in get_folder_shallow_md5
    files = sorted(os.scandir(str(folder)), key=lambda f:
FileNotFoundError: [Errno 2] No such file or directory: '/home/jhanarato/suttacentral/static/text_images'

CherryPy Checker:
'/home/jhanarato/suttacentral/static/text_images' (root + dir) is not an existing filesystem path.
section: [/text_images]
root: '/home/jhanarato/suttacentral/static'
dir: 'text_images'

Metta :slight_smile:

@Blake - can you please have a look at this? Thx.

You just need to create that folder. I’ve also added it to the git repository (by creating a .gitignore in it) so a git pull will also fix it.

Morning Blake!

I think you need to add the text_images to static rather than the project root directory. I get a few errors when connecting to the server at localhost, seems they relate to elastic search which I’ve not set up yet.



Ahh… interesting.

There is now a purple bar with the text - Local Development - master - 8d546b26 -

All well and good, except it displays on top of the sutta central main menu.

I’m running Firefox 43 on Linux Mint.

You can disable the development bar in local.conf

Without an elasticsearch installation, the search and a few other features wont work, but most of the site should work fine.

OK, no more bar.