SuttaCentral

Mindfulness at the Computer: Alpha 5 Release

software
Tags: #<Tag:0x00007fc456e6cab8>

#1

Mindfulness at the Computer: Alpha 5 Release

Mindfulness at the Computer is a mindfulness and self-care application for people spending a lot of time in front of the computer

The application reminds you to take breaks from the computer, helps you remember to stay in touch with your body and be mindful of your breathing and body while sitting at the computer, and helps you concentrate on your inhaling and exhaling when you need a breathing pause

Direct Download

GNU/Linux - click to download

Requires a 64-bit Linux-based OS that is less than two years old, for example Ubuntu 16.04 or later (because of a dependency on glibc)

MacOS - click to download

Works on MacOS High Sierra or later. (May work on earlier versions as well)

Windows - click to download

Works on Windows 7, 8 and 10 (64-bit)

New in alpha 5

  • Breathing phrase settings simplified
  • New feature: User can now suspend the application for a selected amount of time
  • New feature: User can now choose that a random breathing phrase is selected
  • New feature: Preparatory notification before the breathing dialog is shown

Complete list of changes from alpha 4

Help Us

We are grateful for feedback, for example please contact us if you

  • find a bug
  • have a suggestion for a new feature
  • have ideas for how to improve the interface
  • have feedback about what you like about the application and how it helps you when using the computer (we are looking for testimonials!)

You can reach us by joining our gitter chat. Also here is our github project page

matc-logo


Mindfulness at the Computer: Alpha 4 Release
#2

Thank you for the updated version!

But… now I did accidentally delete the icon from starter bar, and I don’t know how to get it back there! :scream:

Can you help me?


#3

I did accidentally delete the icon from starter bar, and I don’t know how to get it back there!

@sabbamitta Do you mean from the system tray (lower right area on many systems)? In that case you just need to start the program again

Or if you mean a shortcut then you can create a shortcut by finding the executable file (in the base directory for the application) and then how to create a shortcut will vary between systems, it may be that you need to right-click-drag the file to the desktop (or another place), or in my own case (i use LXDE) i left-click drag and hold the ALT key, and when i drop the file (on the desktop for example) i will get a popup menu which has the option “link here”

Hope this helps!


#4

I mean the (in my case) left hand sidebar from where I can start different applications:

Bildschirmfoto%20vom%202018-05-15%2015-56-53

It used to be there, and when starting my computer I could start the app from here. Now I have to start it by using the executable file each time.

When started, a small icon will be visible in the upper right corner of my screen:

Bildschirmfoto%20vom%202018-05-15%2015-56-08

Here I can for example open the settings, or “take a break now”, etc. But when I close the app this disappears.


#5

@sabbamitta Okay i understand, i have used this interface before and if i remember once you start an application it will be shown to the left and then you can right click to “pin” it to that area so that it’s always shown there, even when it’s not running, can you do this for our application also?

Is there a difference from how alpha 4 works? We haven’t made any changes to this AFAIK, though the underlying Qt framework has been updated


#6

Yes, it was as you describe when I first started the alpha 4. I pinned it there, and there it remained. But now I deleted it accidentally, and I can’t get it there again. I have even deleted the app from my computer and downloaded it again (alpha 5), but it didn’t help.


#7

Can you open the app from the folder you downloaded then pin it once open? (just a note on the run, sorry if not any help)


#8

I’ve asked in our project chat to see if anyone knows an answer to this, i haven’t been able to find a solution myself when searching, only this complicated approach which may work for you: https://askubuntu.com/a/224021/360991


#9

Not sure but you may be able to simply drag the application executable to the launcher


#10

This sounds far too nice & easy, but unfortunately doesn’t work. The other one looks indeed a bit complicated, and I’m not very much tempted to try it out right now. Maybe when I’ve looots of time… :sweat_smile:

But thanks for your advice, both of you, anyway! :heart:


#11

Just experimenting, turning the app on and off.

Sometimes when it is on there appears a question mark in the launcher, sometimes two (sometimes none):

Bildschirmfoto%20vom%202018-05-15%2016-29-05

Sometimes it is possible to pin one of them to the launcher, sometimes it still disappears when closing the app. In any case, even if it remains, it is not possible to start the app from the question mark.

Strange… :thinking:


#12

I remember having a problem like this previously back when i was using Ubuntu myself, but i can’t remember how i solved it. Maybe you can ask here? https://askubuntu.com/


#13

I’ve now tried everything:

I have re-installed the old app—then my icon is back in the launcher. But… I cannot pin it there. Each time I try it doesn’t keep.

And in any case for the new version this doesn’t work. No icon, whatever I do. If I want to use the app (old or new) I have to open the folder each time and start it with the executable file.


#14

Okay, thank you for reporting this. Can i ask which version of Ubuntu you are using?


#15

All: Has anyone tried the new “random breathing phrase” feature? It’s available in the “dialog” section in the settings where you can change it (default is “same” but we are changing the default to “random” in the next version)


#16

Ubuntu 16.04


#17

Finally, after a day or so of rest and at a new boot of my computer the old app gives me now the launcher icon again and allows to pin it where it belongs. So I’m using the old version… :grin:


#18

Okay, i’m glad that is working. For alpha 5: could you ask on https://askubuntu.com/ if they can help you with your problem there? (I could ask instead but there may be follow up questions that i can’t answer)


#19

I just got a notice from my virus scanner that it has quarantined the alpha 5 release because it believes it is infected with malware, classified as Win64:Malware-gen. However, according to How to remove Win64:Malware-Gen Trojan (Virus Removal Guide) , that’s their name for a generic Trojan. So it could be a false positive. Has anyone else run into this issue?


#20

upload it to virustotal.com see if other virus scanners detect anything