Safari should be working now

So here I am wondering whether I should be crossing fingers and touching wood, or invoking some long-lost deity, but anyway we think the super-annoying Safari bug is dead. Our patient and beloved Safari users, please let us know if all is (mostly) right with the world.

To be clear, the bug we fixed is the “nothing at all shows on Safari” bug, not the weird “missing diacriticals” or other minor bugs. Let’s get the site there at least!

It seems the problem was something in the nginx server settings that confused Safari and made it freak out. At least, that’s the non-technical version! We had the site working (mostly) fine on iOS 5 last night, so we’re hoping the major hurdle is cleared.

Of course there are still some minor bugs remaining, and we will attend to those in due course.


It took a few refreshes after clearing my cache but ‘3 BIG SADHUS’
:smile: :smile: :smile:
:fireworks: :fireworks: :fireworks:

I’m only getting the one error on my phone

[Error] Refused to load,700|Roboto:400,300,300italic,400italic,500,500italic,700,700italic because it does not appear in the style-src directive of the Content Security Policy.

It also seems to load better on Safari desktop.


:tada: :tada: :tada:
Very happy it works now!
Don’t worry about that error because we are not using that font. One of the standard Polymer libraries uses that one but it is not used on the site.


A minor…ish formatting problem in the sutta cards. They don’t seem to collapse on tiny screens and this throws out the header.

1 Like

Hmmm … yes, that’s no good. Will report it.

So good to see it working finally!

I saw the same display bug on the iPhone I used here, we’ll check it out.


@sujato @Vimala @Pasanna

Yey, just tried it and it opened!!! :kissing_heart:Thank-you so much. Can’t spend any time at all on it at the moment but just had to at least check to see if it opened when I saw your messages. Can’t tell you how excited I am.:anjal:

BTW, I only tried on my desktop mac (version 10.1.2)


It’s working fine here on Safari version 10.1.2
Thanks for all the hard work.


Works fine with Safari 11.0.3 macOS 10.13.3, and Safari iOS 11.2.6.


Works ok - it opens up. However each time I hit reply, the text box menu is ‘squashed’. Something to do with the size in which it’s displayed I think. I can’t take a photo as the phone is refusing to take a screenshot!

With metta

1 Like

Hi Mat,
I think you are talking about the forum and not about the SuttaCentral website itself. We had a problem on the site with Safari not working but the forum has not changed, only the looks have changed. If that theme does not work for you, then just change it back to the old theme by going to your preferences --> Interface, select the old Legacy theme and Save.

Hi Bhante, it’s still not working for me :frowning: Mac OSX vers 10.7.5. Safari 6.1.6. I’ve deleted all my browser history and data etc etc. but it’s still totally blank.

1 Like

Did you try private browsing window too?

1 Like

I don’t have the option to browse privately in Safari - my version is so old. I’ve checked for updates but there’s nothing available for my OS.

1 Like

Ah yes. It’s working fine now. The previous version seems to work on my iPhone 6s.

1 Like

Dear @sundarashanti,
I think it is indeed that your version is too old to support webcomponents/shadow dom. We have tested back to Safari 9 but 6 would definately be too old. You can however use the old site at


Dear Venerables and tech devas,
There is still one small ‘glitch’ for safari I have noticed with the homepage.

If I browse to the SC homepage (via entering the URL) the first time the page loads it leaves a large gap between #tabscontainer (the horizontal menu) and the following horizontal element. It’s approximately the height of my browser window (100vh). The gap is #FFF not the off white you have selected for the design.

Additionally, if I scroll the top section (everything above and including the horizontal menu) flickers. However, if I then refresh my browser window, the page loads as I believe it should be rendered with ‘The wisdom of the Buddha has been preserved in a vast ocean of ancient texts.’ sitting around 145px (on desktop) below the horizontal menu.

This occurs both on my desktop Safari 11.03 and on my older iOS version (10.3).

If it’s helpful I can reproduce it and capture things from the inspector.



Thank you Venerable!
I’ve made a ticket for this.