Sutta central has stopped working for me! Can anyone help?

Hi, when I try to open sutta central (the main site not the forum) I am presented with this screen I can’t get past. Does anyone know how to solve this?

It’s fine on my side. So, I am guessing, maybe you can try it on the desktop? Or a different phone? Or a different browser app? A possible scenario is maybe they were upgrading it and you need a hard refresh.

Hope it will be ok for you soon :pray:. If not, I think you might need to ask for contacting the technical team.

1 Like

There was an update yesterday, so please use a hard refresh.


  1. Hold down Ctrl and click the Reload button.
  2. Or, Hold down Ctrl and press F5.

Mac OS:

  1. Hold down ⌘ Cmd and ⇧ Shift key and then press R.
  2. Or, hold ⇧ Shift and click the Reload button.

I’ve tried this twice now with no luck, including also restarting my phone.

Assuming the above advice didn’t work, let me ask a few standard questions. Probably you’ve thought of these but we have to make sure!

  • are the buttons you see on your screen clickable? Try clicking them! Especially the Home button, but anything really.
  • Can you try with a different browser?
  • do you have any extensions in your browser
  • it looks like the app is only partly loaded. So make sure that you have a good network connection.

If that doesn’t work, may I ask what is your phone OS and number?

1 Like

A browser cache clear for caches files fixed it up for me 11 hours ago. I had not tried a shift-refresh.

1 Like

Hi Bhante, thanks for the help! The buttons do seem to work, or at least some of them. When I press the language button it gives me the options to change it. The issue happens to me using both the safari and Google chrome browsers on my phone. I don’t believe I have any extensions loaded and I have excellent wifi. I have tried clearing cookies and cache multiple times to no luck.

My device is an IPhone 13 running iOS 16.1.1

Thank you!!

Okay thanks.

Oh, another test, try it in Incognito. Does that work?

@HongDa can you look into this? Maybe check the logs and see if there are any errors recorded?


I get the same issue in incognito

1 Like

Arrrrgg! So sorry, and thank you for your patience!

It may be an obscure bug in Safari, we do test in Safari but it may be a different version. Hopefully Hongda can help you, because I’m out of ideas!


Thanks for your help! I don’t think it’s a safari issue since it’s also an issue with chrome. Chrome is actually where I first encountered it.

Sorry to burst the bubble, but on iOS, everything is Safari. They don’t allow other browser engines. So Chrome, Firefox, etc. are just window dressing: the web rendering engine is all Safari, all the way down.


Wow my mind is blown

Sure, let me check the possible reasons. :pray:


I tested on an iPhone 12 with iOS 16.1.1, and the same problem occurred. When I tested it on an iPhone 13 with iOS 16.6.1, it was normal, so I estimate that this problem can be solved after upgrading.


I have a 6th generation iPad (2017 model) running iOS 16.6 (20G75) and I’m not having any problems.

I made a patch. now when we open the home page, the menu will no longer appear and cover the page.


After testing on multiple versions of iOS, this problem will not occur after upgrading to iOS 16.4 and above.

1 Like

Finally, we solved this problem through a polyfill, and SC can now be accessed normally on iOS versions below 16.4


Thanks so much Hongda, this was a tricky bug with one of our libraries, congrats on chasing it down.

1 Like