SuttaCentral

There's blank pages where there weren't any before

I keep seeing nothing but empty pages. Is everything okay?

3 Likes

I’ve also had trouble with suttacentral.net URLs on my iPad. They started showing up as blank pages in Chrome. I’ve started using my Chromebook to look at suttas. This happens with Chrome on iPadPro using links such as:

I even powercycled my iPadPro to no avail.
IOS: 13.3.1
Chrome: 79.0.3945.73

Same problem with Safari on iPadPro

@blake @sujato @HongDa

2 Likes

OS: Pixel 4
Chrome: 80.0.3987.99

I cleared the cache and refreshed and also rebooted took off extensions tried the app. No dice.

Did a clean reinstallation of chrome, and it was fixed. Hopefully if anyone else has this problem, they’ll be able to fix it

1 Like

Upon reinputting my settings it’s back to being blank pages.

I turned on Sutta references, word lookup and Pāli line by line. It’s back to not working

The error appears to be reproducible. I have tried five times to see if other variables were making a difference. They were not.

I had a friend try the same thing with Chrome, Version 80.0.3987.106 (Official Build) (64-bit), Windows 10 and the error affected him too

Chrome, Version 79.0.3945.130 (Official Build) (64-bit), Mac OS 10.14.6, and I don’t have the problem with regular windows but do have it in incognito windows.

I’m doing a quick check now, I can’t find any problem. Thanks everyone for the bug report, but if it persists, can I ask you to:

  1. Post a URL that does not display for you
  2. Post any error from your console. (right click, inspect, console, the errors are marked in red)

I do not know how to open the console on mobile, is there a way to inspect it on mobile chrome? As I’m not able to right click or inspect the code directly.

From Incognito, literally any sutta page is blank. Examples: http://www.suttacentral.net/mn and http://www.suttacentral.net/mn15 as a random example I happen to have up in my browser. I notice nothing in the console that seems to indicate an error in Incognito.

Actually, there does seem to be an error in the code, but I can’t find it. Here’s a screenshot of my console:
17

Sorry, I don’t know, checking things on mobile is hard.

Hmm, I’ve opened both those pages in incognito Chrome and Firefox, they work fine.

Great, can you click on the “Console” tab, then if the error is not visible, click on the red X icon. Ignore the yellow “warnings”, we want Red!

I just refreshed and MN15 is now there.

Well that’s good but also bad!

My guess is that this is related to a recent update we did. It’s probably not the update itself, more likely a cache issue. Although this would not explain why there was a problem in incognito, usually that busts the cache anyway. Hmm.

I suspect that, if the problem also resolves itself for other users, the best we can do is to wait till the next update and hope it doesn’t happen again.

No luck on my part. I found a way to view the source code but not cleanly.

https://pastebin.com/BmgenqFe

Here’s the code, but here’s what I see…

The homepage (suttacentral.net) is blank for me. Red console error: “Uncaught (in promise) TypeError: Cannot read property ‘call’ of undefined
at a (main.js:1)
at Module.631 (74.js:1)
at a (main.js:1)”

This is on a chromeobook.

1 Like

Okay, thanks for that, I will alert our developers and see what can be done.

I have the same problem. Ipad Pro, Safari & Chrome.