SuttaCentral

Trouble with Pali-English lookup tool

I’m having trouble with the Pali-English lookup tool on SC. Each time I load a new page it doesn’t work. I have to disable the lookup tool, then refresh the page, and then enable it again. And the same again for each new page… It works, but it’s very cumbersome.

1 Like

May I ask what browser you are using, including the version number?

It’s Firefox version 62.0.3 (64-Bit).

Thanks. I’ve just tested it and can confirm the same issue. I’ll enter it as a bug It turns out this is a long-standing bug. I have bumped it as still current (one of our chief bug-fixing methodologies is to do nothing and hope that it goes away!). But it will be awhile before we can get to it.

1 Like

I’m currently having trouble with the lookup tool too. It doesn’t want to show up even with refresh.

But there is a fix:

  1. Turn on the lookup tool
  2. Change the original text with translation: let’s say from side by side to line by line
  3. The lookup is working
  4. Changing page? Redo it.

I’m using Firefox 82 for Ubuntu. All is fine on Chromium though. FYI I installed Chromium just to get offline access to SC. So, offline access for Firefox? :upside_down_face:

1 Like

I also have (slightly different) issues with lookup:

I have to activate both lookup and ‘text with translation’ anew, for each page/sutta. If I refresh the page, or open another tab for another sutta I again have to activate both - the setting is ‘forgotten’ by the browser.

System is W10, and It’s the same for the actual Opera 73.0.3856.284, Microsoft Edge 87.0.664.66, and Chrome 87.0.4280.88.

Any idea how I can safe the settings so that lookup is automatically activated?

1 Like

wait until the site is upgrade. This works on staging.