Pali keyboard on mac os x el capitan


i am trying to get a pali keyboard to work on a mac os x el capitan.

most of the instructions on the internet are written by people with high level IT skills in this area and i am finding it hard to extract the basic requirements to get this function operable without all the associated analysis and discussion.

if anyone is able to give some simple, plain english, step by step instructions would be greatly appreciated, or a link to such.

i have downloaded something called ‘keyunicode’ and put this into system preferences, keyboard, input sources. i have ticked both ‘show input menu in menu bar’ and ‘automatically switch to a document’s input source’. I have restarted computer and then used the mapping chart to try and reproduce a pali font. All unsucessfully unfortunately.

Back to pen and paper until I can get this sorted.

Many thanks in advance for any assistance anyone may be able to give.


Have you seen the post earlier from here:

Perhaps this might help.


thanks sujato. those instructions are basically the same as what i have been doing.

i did however try taking out the files i had downloaded from the tipitaka site and replaced them with these but still no luck… i just keep getting an a with a dot over it for a long a.

i think there is a small step on this newer mac platform that i am missing. most instructions on the web refer to an older platform and the process is not one i am familiar with, so not sure where to trouble shoot…

would you have john kelly’s email as i wondered if he may use a mac? or perhaps i may try ven. punnyavaro at bodhi tree, he may use a mac, will keep perservering…

anyway thanks for trying!

cheers sonya

Macs actually already have Pali functionality without needing to download any external keyboards or needing to create any customized personal settings/keyboards. You need to change your keyboard to the preloaded “ABC extended” keyboard on your Mac.

At the top of your desktop you should see a bar. I am in Canada, so one of the icons on my top bar is, by default, a Canadian flag. Click on the flag icon to open up your keyboard and language settings. In the dropdown menu, select “Open Keyboard Preferences”.

In the Keyboard Preferences menu click the “+” icon on the bottom-left.

You now have a wide range of keyboards and language settings to choose from.

The one you want is called “ABC extended”, and it has an icon of “ABC” rather than a given flag.

If you do not know how to use the ABC extended keyboard (which has all of the diacritics needed for Pali), then, one you have it set as your active keyboard, click the ABC icon on the top bar of your desktop, and in the dropdown menu, click “show keyboard viewer”. Now you can see your keyboard on your desktop.

If you have the ABC-extended keyboard active, if you hold the “option key” than you can see all of the available diacritics.

Option+x together, followed by an upper or lowercase “n” is a dot beneath an “n”: ṇ, etc.

It is very useful. Ṃṃṃṃ-ḥṃ.


Amazing! Perfect! Stupendous! I could use a whole lot more superlatives but instead I will just say thank you, very much. I have been trying for ages to do this and what you showed me was so much simpler than what I had been struggling to do.

It is so nice when simplicity prevails over complexity… particularly across such vast oceans as that between Canada and Australia…

With enormous gratitude and mettā,


hi @Coemgenu

I installed Pali diacritics according to the directions given to me from Ven Punnadhammo (as intructions in @sujato’s post) but I’ve wondered if there was another way. I use a Mac with OS X yosemite and out of curiosity, just tried your instructions. When I open ‘keyboard preferences’ the only two that show up are a US flag and the one I (well actually my husband who helped me) created according to the instructions I shared, which we named ‘Pali’, which I switch to when I want to use diacritics (and I then use the keys that the instructions specified). Where do I find the “ABC extended”? I’m not very tech-liternate (to put it mildly).

@sonyanourse, I can relate to your previous frustration. I was lucky to see something on the web a few years ago (pre-SC discourse) when I was researching studying Pali which led me to some Pali resources on Ven Punnadhamma’s website. So I e-mailed him to ask how he did diacritics and he was kind enough to respond and send me those instructions (which at least my husband managed to get working). Before that I also had been trying to use files from the tipitika site and getting nowhere.

We’re so fortunatel to now have SC for such questions and help!


1 Like

the only suggestion i can make linda, is to check that you have english highlighted in the left hand column, then abc extended automatically shows for selection. for some reason mine was on arabic - i think it was just the first in the list - that took me awhile to figure out - ha!ha!

good luck with it, works very easily - now for pali!

i’m sure others more experienced could give you more assistance tho’…

yes, SC is definitely a wonderful resource. look forward to connecting with more people in the dharma.

ciao ciao


I am using the pāli keyboard on el capitan.
Get it here:



hmmm, after clicking the ‘+’ icon as per @Coemgenu’s instructions, English is at the top and highlighted but there is no keyboard option with an icon of ‘ABC’ on it, just different flags for various English speaking countries and then some icons called ‘colemak’ and ‘dvorak’, whatever those are.

Well, I can keep using Pali diacritics the way I’ve been, but was wondering so if I change my computer I won’t have to go through setting it up as with this one.

My apologies, I see you’ve tried to install the tipitika keyboard. I’ll try and give better instructions :slight_smile:

I remember now, that when I installed it I didn’t think it worked because holding down the a-key didn’t bring up a long a. There’s a few things you need to do…

After installing the files…

Go to the Apple menu > System Preferences
Click Keyboard
Choose the ‘input Sources’ tab
Click the + symbol at the bottom
From the lefthand column (languages) choose ‘Others’.
EasyUnicode® should appear in the right column. Select it and click ‘Add’

You should now have 2 keyboards available. Mine has Australian and EasyUnicode®.
Tick the box that says ‘show in top bar’.

You can now close system preferences.

Up next to your clock is a flag (mine is Australian) click it and choose the EasyUnicode® keyboard. The icon will change from a flag to a black keyboard.

You cāṇ ñōw ṭypē Pāli chāṛācṭērs. You will find the unicode letters ‘hidden’ under normal keys. To activate them hold down the option key and press a letter. Long a (ā) is option+a.
Hold shift and option down to get capitals.

The characters are mapped as follows

option+a = ā
option+d = ḍ
option+g = ṅ
option+j = ñ
option+k =ṅ
option+e= ē
option+t = ṭ
option+u= ū
option+i = ī
option+c = ñ
option+n = ṇ
option+m = ṃ
option+, = ṁ

I really hope this was more use!


[quote=“Linda, post:6, topic:4558”]
When I open ‘keyboard preferences’ the only two that show up are a US flag and the one I (well actually my husband who helped me) created according to the instructions I shared, which we named ‘Pali’, which I switch to when I want to use diacritics (and I then use the keys that the instructions specified). Where do I find the “ABC extended”? I’m not very tech-liternate (to put it mildly).
[/quote]Hmmmm. Your OS X Yosemite should have had that keyboard preinstalled as a possible setting from when you last updated to Yosemite I think.

Try going to the Apple menu and clicking on “System Preferences”, then clicking on the “International” icon in System Preferences (it might be listed instead as “Language & Region” depending on how Yosemite is organized), now you should click on the “Input Menu” tab and select what keyboards you want, alternatively, if Yosemite does not have an “Input Menu” tab, click on “Keyboard Preferences” and try pressing the “+” from here, when you click on “English”, if it still doesn’t list “ABC, ABC Extended, British, British - PC, Canadian English, Colemal, etc” then you might need to see if your Yosemite needs updating, which I assume you would do at the Apple Store or something, or in System Preferences possibly. I would try looking for an update possibly called “International Support” or “Language Support”.

1 Like

In el capitan, the library folder can sometimes be hidden. So to add to my above instructions you might need to do the following, once downloading the zip file…

Go to your Downloads folder and double click the zip file to unzip it. Then open the new folder.
In finder (where you can see your folders), go to the File menu and click New finder window. You should now have to finder window
go the Go menu and choose 'Go to Folder’
Find the ‘Keyboards layouts’ folder
Drag the file ‘EasyUnicode®.keylayout’ from the EasyUnicode5 folder to Keyboard Layouts…

Proceed with my instructions above

1 Like

Thanks for your suggestions @Coemgenu. I can’t figure out why ABC isn’t showing up unless it’s going by another name. My yosemite is up-to-date and trying via ‘Language & Region’ in ‘system preferences’ doesn’t yield anything different (just all the various languages as listed in keyboard preferences as well.

I went back & tried again by opening keyboard preferences as in your first instructions. I click on the US flag on the left, then the ‘+’ button, and then the box on the right shows several flags of the various English speaking countries (Canada, Australia, British, Irish). In addition, there are icons called C-Colemak, DV-Dvorak, Dvork left, Dvorak-Qwerty, Dvorak right, US Extended & US International. Don’t know what any of these are but I did try using the option key with the keyboards on the US Extended & US International & Colemak. It gave various symbols but not Pali diacritics. There is definitley nothing called ‘ABC’… hmmmm

[quote=“Linda, post:13, topic:4558”]
In addition, there are icons called C-Colemak, DV-Dvorak, Dvork left, Dvorak-Qwerty, Dvorak right, US Extended & US International.
[/quote]The US International keyboard did not have Pali functionality? ABC extended definitely has it, I am wondering if it is replaced with “US extended” on American machines.

Even though you have Yosemite, maybe try @Pasanna’s advice above?

1 Like

Thanks so much @Coemgenu (and @sonyanourse). The ‘US extended’ worked after all! I had tried the "US International’ which did not–it just gave a few common diacritics from other languages and only one (the tilde above an ‘n’) was useful for Pali.

Anyway, I thought I had also then tried the ‘US Extended’ but it turns out I had forgotten, after I added it, to highlight it and still had "US International’ highlighted. So wow, it works now. Thanks for your help, really appreciate it. So it looks like ‘US extended’ does replace ‘ABC’ as you suggested.

So grateful! Was able to install and use (and finally read text without bizarre symbols) easily. :pray:t3:

Hi @MindfullWayfinders ! Welcome to our community! Do have a look around… you can explore many more topics through the search bar. Happy exploring! :slightly_smiling_face:


Grateful. I’ve poured over the site for a while, and find it immensely valuable. Glad to be in the forum to discuss. :pray:t3: