SuttaCentral

The search function is behaving oddly

I can’t open the search window it keeps closing and when I am able to write in it it jumbles what I say.

4 Likes

:slight_smile: yesterday I queried for “fetters” and got zero results for “srettef” repeatedly also using Chrome. (I manually edited the url with query= and got results.) (Poking query also got that behavior of instant close / return to prior results).

But I am also seeing the same behavior today in both Chrome and DuckDuckGo browsers, and in the android SuttaCentral ap (which might depend on Chrome, I think).

1 Like

I am seeing the same problem of instant closure on the same version of the Chrome browser as above, but with Android 8.1.0. Usually the soft keyboard closes immediately, but when it does not the characters entered on the soft keyboard are not echoed but the search string is sent to SuttaCentral in reverse order as you have noted @ERose. This is quite recent behaviour since I use the search feature frequently.

I see no problem with search on my Ubuntu desktop version of Chrome. So I tried enabling “Desktop site” on my Android. But no luck.

David.

1 Like

I had a different but maybe related problem with search yesterday. When I click on this


I get this:

3 Likes

I had that yesterday. After following the advice the problem fixed itself

That whole thread is related to the blank pages issue :slight_smile:

I hope you are well :slight_smile: with metta :smiley:

6 Likes

It appears that this issue hasn’t been addressed yet :slight_smile: @musiko @karl_lew @sujato @Snowbird

2 Likes

@hongda, @blake some more problems…

2 Likes

The version of the problem on my Android device is related to the on-screen keyboard. When the keyboard pops up, the text input field for the search disappears and characters are entered right to left.

David.

1 Like

Thanks all for the feedback!

Yikes! Trying to reproduce it, I can’t see the “jumbled text” problem.

But I do see the “instant closure” problem. We recently introduced a bugfix for another issue with the search field on Firefox, it seems we introduced this regression. I’ll alert @HongDa and we’ll fix it ASAP.

5 Likes

Sorry for the inconvenience. I have fixed this problem and redeployed the website. Please see if the problem has been solved, thanks!!!

8 Likes

I am no longer seeing these problems on my Android, which is the only place I saw any of them. I have never seen the word reversal noted by @CrystalSpires. Anyone else?

As I had reported before, I had seen it; also saw it briefly today. But nothing as bad and consistent as it briefly was.

Thankfully it has gone away for me. Thank you and I hope it goes away for good. I am not yet able to recall Suttas by memory so being able to search by relevant quotes I remember is easier on my brain. Thanks folks on Suttacentral and Venerable Sujato.

6 Likes