SuttaCentral

Report bugs for the new site here! 🐛


#307

Great Work on the new site. Much Metta!

To add to Stu’s finding … after one highlights the text (text1), then highlights a new section of text (text2), non-showing of pali definition in text1 persists. This non functioning persists with future selections as well.

Keep up the great work!


#308

The display for the badges page seems to not quite look right- text flows past the badge in some places, doesn’t wrap, and is too short to actually see what the badge is for in many cases.

Chrome on MacOS.


#309

Yes, the css for the new theme is not that great. At some point we will look into it but have a lot of other things on our plate at the moment. However, you can always switch back to the old theme if you want in your settings.


#310

No, this is caused by the way the abbreviations are handled. The translation is inheriting paragraphs from the Pali text, but has abbreviated a bunch of repetitions. My plan is to assess and adjust these issues at some point in the not too distant future. Hopefully such problems don’t occur too often.

Sorry, I can’t follow this; nor can I locate the message by Stu that you’re referring to. Can I ask for some more explanation?


#311

Sorry for replying in the wrong place …

This was referring to a post by Stu on March 20. I paste part of his original post below …


Going to a page with a segment number (or clicking a segment number once in a page), e.g. SuttaCentral1

Settings: View textual information is on; side-by-side; Pali - English

Hovering over any pali word outside the selected segment works as expected and brings up the pali dictionary definition:

[picture from original post]

So the above is very cool, but hovering over a pali word inside the selected segment does not show a pali definition. I can’t supply a screenshot of that because PrtSc doesn’t show my cursor.

Windows 10 Pro; Version 1709; OS Build 166209.309
Google Chrome Version 65.0.3325.162 (Official Build) (64-bit)


#312

Yes, you are right. We have noticed this too and have already an open issue ticket for this on GitHub:


#313

I think at the moment it’s best just to wait for P3 before trying to fix this bug.


#314

I’m seeing a weird formatting glitch at SuttaCentral
with the side-by-side rendering getting jumbled into multiple columns with interleaved English and Pali.
(Window 10, Chrome)


#315

I can’t see this in the page you link to. Did you try refreshing the page?


#316

I also don’t see it anymore.


#317

The biggest bug I’ve found is this: I’ve read several suttas, including the new translations, and I am STILL not enlightened. Please fix this ASAP.

:stuck_out_tongue_winking_eye:


#318

Noticed font problem here, in title and text:

image

Waterfox 56.2.1 (64-bit)
Windows 10

Refreshing didn’t fix. Sorry if this has been reported


#319

Well let us know if it recurs.

Yeah, not sure what this is. It has been reported and will get fixed in due course.


#320

Congratulations on delivering such a sophisticated app. The tech and content are both of an amazing calibre.

I’ve noticed sometimes when I visit the home page I get a blank screen (similar to what @Linda described). Unfortunately it happens intermittently, so I haven’t been able to define steps to reliably reproduce the error. I’ve only seen the issue occur on Chrome (Windows 10 home) and android (though I’m not sure if it was because of the same issue as I couldn’t check the console). It happened again about 20 minutes ago so I took a screenshot of the console:

But that said I can’t seem to recreate it anymore. From the console it looks like something caused by a 3rd party, not because of Sutta Central, maybe they fixed it on their end? But I figured I’d report it anyway.

Thanks for all the hard work.


#321

When viewing the PTS Pali page image (from the English translation), there are a set of controls at the bottom that are very handy (zoom and navigation). However the full set of controls only appear when I am using full screen mode of the browser (Chrome on Windows 10 Pro). When I have a reduced pane (which is what I need, to read what’s in the image at the same time as the text coding I am comparing it to), I only get the navigation controls (previous and next page), not the zoom. Unfortunately, the image displays at a size that I can’t read, with my old, tired eyes. Thanks for your help.


#322

Thanks!

Okay, and thanks for the screenshot. I am not sure about this, but I’ll post it as a bug and see if we can sort it.

Yes, could be. In any case we are planning to upgrade the whole app soon, and part of that will be further reliability and performance testing.

Hmm, okay. The widget for doing this is simply imported from somewhere else, and was chosen on the basis that it worked! I don’t really like it, but it does the job, mostly. I’ll see whether we can upgrade it.


#323

Same for me, @greenTara. But I can zoom it by scrolling with the mouse.


#324

Ha! Useful discussion. I didn’t even realise we could do that…


#325

In what way do you scroll with the mouse? I only see a hand icon that I can use to move the page around within the pane, but not make it bigger. Are you also using Chrome?


#326

Hah! I figured it out. I use the browser zoom to zoom OUT until the full set of controls reappear, then I can zoom in on the image. A little counter-intuitive there, but it works! Once the browser zoom is set, the controls stay visible. The only annoying glitch remaining is that when going to the next page it reverts to zoomed out, but all the controls are still visible at least.