SuttaCentral

Report bugs for the new site here! 🐛


#143

Oh dear! Maybe there’s a regression or variation in Safari versions. But the log report is great, our devas will be all over this.


#144

I’m more than happy to keep spitting out logs and anything else the tech-devas might need. I will be online easily until around the end of the month.


#145

Cheers, thanks so much. May I ask, why is Mozilla mentioned in the browser version? I see a similar thing, and have never understood it. My Chrome says:

 Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/64.0.3282.167 Chrome/64.0.3282.167 Safari/537.36

Also, maybe you could try staging.suttacentral.net, see how that is for you.


#146

Bhante, I honestly don’t know.

It’s also interesting that I’ve actually got a newer version of Webkit than you.

I have the same 82 errors on the staging site too.

EDIT
@sujato This might be the answer


#147

On my iOS-device, I can now see a little more diacritics with Safari, but not all.
On my macOS machine, I am unable to load the front page or a sutta with Safari, I only get a blank page. It worked quite nice before the recent update.

iOS 11.2.6 (cache cleared)
macOS 10.13.3, Safari 11.0.3 (cache cleared)


#148

Interesting.
I’m on MacOS 10.12.6 (Sierra) with Safari 11.0.3 and the site is doing fine for me.
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6

The only error I’m seeing is:

[Error] Refused to load https://fonts.googleapis.com/css?family=Roboto+Mono:400,700|Roboto:400,300,300italic,400italic,500,500italic,700,700italic because it does not appear in the style-src directive of the Content Security Policy.


#149

Might be a problem with high sierra then?


#150

Do you have Chrome on your mac?
I’d be interested to see if it worked in Chrome in High Sierra


#151

Both Chrome and Firefox are working fine - and show the diacritics right.


#152

I also cleared the cache and still no go on 10.1.2

I jsut tried to delete this post (seeing the discussion was about high sierra, not yosemeti) but don’t seem to be able to, can edit but not delete which was possible before. Am I doing something wrong?


#153

Oouuaaahhh… !!!

Today I tried for the first time to open the new SuttaCentral website on my Android tablet. And what did I find?—A completely blank page!

So this shows that SuttaCentral is the most Buddhist website ever: It takes you to the very perception of EMPTYNESS!!! :sweat_smile:

Android version 5.0.2


#154

I’m using an Android device, an oppo a57. I often use my Google Search widget to open suttacentral. Unless I open suttacentral in chrome, suttacentral does not stay open in a tab when minimised, it dissapears. This website is the only one that I have encountered so far that simply vanishes. I may be in the middle of writing a message. This does not appear to happen when a Sutta is open, only when I am in discuss and discover.


#155

Nice, today suttacentral loads fine with macOS Safari. The problem with diacritics is mildly better - as with the iOS Safari I can see some more of them, but not all.


#157

Thanks for the logfile. That’s helpful. Do you have any plugins running? There have been various reports of plugins like Lastpass and adblockers that sometimes block the site.

From the logfile it looks like it cannot find the Polymer base but will give it to our devs to look at.


#158

We haven’t actually looked at the diacritics problem yet. That’s a very weird bug! It would mean that the browser for some reason is able to substitute characters unless it is simply not showing the diacritics. Can you look in your console and see if the words have the diacritics there?


#159

No need to delete. Your info is still very welcome!
But if you want to delete, you should be able to do so in the extended menu: click on the 3 horizontal dots at the bottom of the post.


#160

Dear Ayya,
do you mean the console of Safari in developer mode? There are lots of errors with “refused to load data:font/woff;base64…” (67 errors for Satipaṭṭhānasutta). But as I mentioned before: when I copy the text and paste it into TextEdit, all diacritics are there. Another related quirk: with the side-by-side feature there are even fewer diacritics shown.


#161

Okay, it might be font-loading related problem and defaults to a sans-serif/serif font instead of using the supplied font. I’ve seen that before in specific instances on Windows 10 and even on my own Ubuntu when trying to load a page through the url instead of the menu. I will make a note of this. Can you see what font it is showing?
Thanks for the feedback.


#162

Well, it’s a serif font, can’t tell more (looks like Times to me). When copying to TextEdit or Pages I lose the initial font information and it is pasted as Helvetica - which it is definitely not in the browser.


#163

Safari has some function called “Show Web Inspector”. It probably has several tabs and one of them shows the css used and the actual font rendered for the site. ‘sans-serif’ is a fallback that uses whatever font your system might have and I have the strong suspicion that it uses a local font from your system rather than the font supplied. But don’t worry about it if you cannot find this info.