SuttaCentral

Report bugs for the new site here! 🐛


#164

Sorry, this took me a while. All I could find out was “font-family: -webkit-standard;” for a highlighted text fragment.


#165

Hi developers. Thanks so much for an awesome new site! ATM I can only view the site on my mobile device because it’s not working on my computer (OSX 10.7). I’ve tried Safari (6) and Chrome (49). Are any other people having the same issue? It’s just loading a blank screen on my browser…


#166

Yes, other people are indeed having the same issue: see above. Tomorrow the devs are back so we will look into it further.


#167

Dear Ayya,
The logfile is from my phone. There are no plugins running in my phone’s browser (AFAIK this isn’t even possible).

I did a bit of searching and found a report on this problem with Safari and ES6

Also in post 146 I think I have the error from the diacritics/font loading problem.


#168

No, that’s a Roboto font that is loaded in the Polymer library but that is not used anywhere on the site. We use Skolar as primary and Noto as fallback.


#169

Please ignore and sorry of that has already been reported.
Before cliking on the ‘2 REPLIES’ button:

After clicking on it - the user’s photo/image is mixed with another user in the thread (dog face instead of Green Y for this example):
image

I’m using Firefox Quantum 59.0.1 (64-bit)

Good luck!


#170

This thread is actually about bugs for the new suttacentral site. On Discourse, nothing changes accept the standard theme. We can do a few things with that like but we cannot change it’s actual behaviour. If you find it bothersome in some way, you can change back to the old theme by going to your preferences --> interface, change the theme and save.


#171

Oh sorry, I mixed the two! I will delete my message. Thanks!


#172

Oh no, please don’t delete it! It’s fine to have your message here and it might be helpful for others too. Maybe we should have made another thread for the Forum itself. Don’t worry about it.


#173

Going to a page with a segment number (or clicking a segment number once in a page), e.g. SuttaCentral

Settings: View textual information is on; side-by-side; Pali - English

Hovering over any pali word outside the selected segment works as expected and brings up the pali dictionary definition:

So the above is very cool, but hovering over a pali word inside the selected segment does not show a pali definition. I can’t supply a screenshot of that because PrtSc doesn’t show my cursor.

Windows 10 Pro; Version 1709; OS Build 166209.309
Google Chrome Version 65.0.3325.162 (Official Build) (64-bit)


#174

Interesting new bug! Thanks for finding. I will look into it. The segmented texts are quite complex because there are many features that interact with each other.


#175

Dear Venerables and tech devas,
There are a few layout quirks on tiny devices which I thought I’d bring to your attention.
iPhone 5 Safari for iOS 10.3

The footer navigation is overlapping when there are long sutta names.

Although improved, the sutta cards are still blowing out the width of the page.

The search box on the sutta-card page does strange things to the header

Sending karuna to you all as I know the dukkha of layout quirks. I keep wanting to make suggestions based on the bootstrap framework! Alas I am not familiar with this one.


#176

Thanks! It seems there are various positioning issues with certain Safari devices. I can’t help but wonder if they are different manifestations of the same underlying bug.


#177

Dear Venerables and technicals, :slight_smile:
I just had a weird experience where I searched a word and at first the search result said ‘zero results found for xxx’. Then after a few seconds it showed me 732 results. My connection is reasonably good and I’m in Chrome (Version 65.0.3325) for Windows 10 (heaven forbid!).

further along my adventure in Windows 10…

And then I did this search and clicked on the title out of habit (Vajira SN5.10). It took me to the Bodhi translation. I then wanted to see the side by side pali with lookup. I clicked the cog and ticked the relevant setting… nothing happened … I tried again. Then I opened the sutta card and switch to the Sujato version and it showed the settings I was after. To figure out what happened I clicked back a few times and notice that the search results uses what looks like ‘material tiles’ instead of ‘material cards’ and doesn’t offer the usual translation option in the suttaplex.


#178

I gather things are being changed / updated on the run here…

Right now, image imports (.jpg files) appear in huge font sizes; and also various places in the overall frame show overlapping words due to rendering in large font sizes.

But nothing critical to the functionality I use, as yet.


#179

:scream:

It probably takes a little while to do the search. We have 60.000 texts so it’s not that easy.

When we roll out the new version, it will tell you the name of the translator underneath each item in the search.

Side-by-side view is only possible on Bhante Sujato’s translations.
Pali lookup only works on pali texts. So you either have to select the pali text entirely, or indeed side-by-side or line-by-line view on Bhante Sujato’s translations (and soon some of Ajahn Brahmali’s translations too, but it takes a long time to convert them - I’m working on that).

If I understand you correctly, you are saying that the search results do not show the suttaplex cards. This is indeed so. They only show the texts where the specific search term appears, which can be any translation or multiple translations of the same text. You can finetune it a bit with the top dropdown menu and just search for root texts (like pali) or dictionary or translations.

In the new version we will roll out soon you can also search for a sutta number and then you get the suttaplex card for that number on top of the search results.


#180

Apologies if this has been posted already, but it appears that in-post links from this forum to the site are no longer being automatically created. For example, I just posted about MN 63. With the old site, I could click on “MN 63” in the post and it would take me to that page on SC. This no longer occurs.

Windows 10. Tried on Chrome and Edge.


#181

I will wait for the update for the previous quirk.

I might have another though.
Clicking a link to a paragraph number from an external referee removes the div I’d from the URL and lands you at the top of the sutta.

In our discord sutta group this morning we where finishing a sutta we started last week and had SuttaCentral as our link. But clicking it redirected us to SuttaCentral

If I then typed the #25.1 it would jump back down.

Maybe a rewrite problem.
Occurred for everyone in our group


#182

SN 46.38 is missing from the list of suttas


#183

Yes, this is broken on D&D, we will fix it when we can.