SuttaCentral

Report bugs for the new site here! 🐛


#387

Thanks for spotting!
No, it’s an error. The word definately exists in the dictionaries:

{
32413: “word”: “nīvaraṇa”,
32414: “text”: “

Nīvaraṇa

neuter, occasionally masculine an obstacle, hindrance, only as tt. applied to obstacles in an ethical sense & usually enumerated or referred to in a set of 5 (as pañca nīvaraṇāni and p. āvaraṇāni), viz. kāmacchanda, (abhijjhā-)vyāpāda, thīna-middha, uddhaccakukkucca vicikicchā i.e. sensuality, ill-will, torpor of mind or body, worry, wavering (cp. Dhs. trsl. p. 310) DN.i.73 (˚e, acc. pl.), DN.i.246; DN.ii.83, DN.ii.300; DN.iii.49 sq., DN.iii.101, DN.iii.234, DN.iii.278; SN.ii.23; SN.iii.149; SN.v.60, SN.v.84 sq., SN.v.93 sq., SN.v.145, SN.v.160, SN.v.226 SN.v.327, SN.v.439; MN.i.60, MN.i.144, MN.i.276; MN.iii.4, MN.iii.295; AN.i.3, AN.i.161 AN.iii.16, AN.iii.63, AN.iii.230 sq.; AN.iii.386; AN.iv.457; AN.v.16, AN.v.195, AN.v.322; Snp.17 Mnd.13; Cnd.379; Pts.i.31, Pts.i.129, Pts.i.163; Pp.68; Dhs.1059 Dhs.1136, Dhs.1495; Vb.199, Vb.244, Vb.378; Ne.11, Ne.13, Ne.94; Vism.146, Vism.189; DN-a.i.213; Sdhp.459, Sdhp.493 and passim. Other enumns are occasionally found e.g. 10 at SN.v.110 SN.v.8 at MN.i.360 sq.; MN.i.6 at Dhs.1152.

Sk. *nivāraṇa, nis + varaṇa of vṛ; (vṛṇoti), see nibbuta & cp. nivāraṇa


32415 },

The lookup tool works fine with this word.
I’ve made a ticket for it:


#388

Popup also unreadable on Chrome/Chromebook.


#389

When I copy the segmented Pali in Chrome from one of Bhante Sujato’s translations, and then paste into LibreOffice, every space is replaced by a non-breaking space.

I tried it from here: SuttaCentral

This does not happen when copying from Firefox.

Unrelated, When I copy pali and english from either place, it mushes everything together. For example,

aaaaaaaaa
111111111

bbbbbbbbb
22222222222

cccccccc
33333333

becomes
aaaaaaaaa 111111111 bbbbbbbbb 22222222222 cccccccc 33333333

Is this a known thing/feature/bug?


#390

Some HTML bleed to the title of text when searching


#391

Thank you for reporting @calvin_sad!
The Theragatha was recently moved to the segmented files. When I go to the file I notice also that in paragraph 4 and 6 there is a * in front of the sutta. I had taken those out over 1.5 years ago! So I wonder if a very old version was used to create the segmented files and not the updated version. @Sujato?

This is the code that was removed a long time ago that generates the *:
<span class=\"cross\" title=\"(gāthā 676--678) ^dhp273-289#274.1 [273. " "Pañcasatabhikkhuvatthu/274. Aniccalakkhaṇavatthu]-301 | ^ne4#1 [Vibhaṅga/ " "Desanāhāravibhaṅga]\" id=\"note311\">*</span>

The code from May 2018 is here: sc-data/thag15.1.html at 506063e970e3fda65c266265f6c5fcdcc6dce605 · suttacentral/sc-data · GitHub

There you see that that cross-span is no longer there. So how come it re-appeared?
I think the segmenting needs to go over too because the var tags are still there and obviously some other things that did not segment right.

I added this to this issue because it is caused by the same bug:


Please report any errors or typos!
#392

Try copying it into a plain text editor like Sublime, Notepad++, Atom or something like that. That will work. Then from there you can copy it again into LibreOffice.

I just copied this:

so i have heard.
evaṃ me sutaṃ—​
At one time the Buddha was staying near Sāvatthī in Jeta’s Grove, Anāthapiṇḍika’s monastery.
ekaṃ samayaṃ bhagavā sāvatthiyaṃ viharati jetavane anāthapiṇḍikassa ārāme.
There the Buddha addressed the mendicants:
Tatra kho bhagavā bhikkhū āmantesi:


#393

I have the same issue on Chrome 72.0.3626.101 on iOS 11.4.

:pray:t3:


#394

Hi,

The instances of the bug that I’ve found so far are for words that have multiple entries in the PTS PED that are almost the same, that is identical when the diacritical marks are removed:

So Jaṭa Jaṭā Jāta/Nivaraṇa Nivāraṇa Nīvaraṇa/Pura Purā.

David


#395

Thanks. Will have a look. I actually made some changes to the system as it was not caching more than 2 entries in the dictionary at the most. But it has not been pushed to the main site yet.


#396

Can you please check if it works according to how you would expect it on staging.suttacentral.net (open in incognito window to make sure you don’t run into any cache issues).

Make sure you enter no capitals in the search.


#397

Ven. @Vimala ,

Thanks so much! I’ve checked as you suggested. The individual issues described below are fixed in staging (Chrome & Firefox on Ubuntu, Chrome on Android). I don’t have the automated tools in place to test whether you have inadvertently introduced new bugs. I’ve done some spot-checking, however, and things look good so far.

David.


#398

Perfect. And thanks for checking. We should have it on the main site soon.


#399

Ven. @Vimala

Again thanks to you and all the folks at SC for your great work!

There is another ongoing issue that I haven’t been able to find here or on the GitHub site: the lookup functionality doesn’t strip all the punctuation from the beginnings and ends of words before invoking the lookup tool. This is really only a minor issue, except in cases of compound words. It’s normally a simple matter to manually remove the punctuation from the URL. But for compounds beginning with punctuation that is not removed are not passed to the analysis heuristics.

This issue especially affects the treatments with words beginning with a single quote (’).

David.


#400

Well spotted! I will have a look!


#401

Sorry if this has already been reported, but I can’t scroll the navigation drawer on mobile anymore:


#402

The grey scrollbar is visible in your screenshot. Can you still move that?

I tried on my android and it also did the scrolling through swiping as well as the scrollbar.

What is your OS and browser version?


#403

I am on Safari on an iOS 12.1.4 iPhone 6s. Yes there’s a scrollbar but swiping up and down does nothing. Only swiping sideways closes the drawer, so perhaps the gesture is getting captured by that?


#404

We are aware of issues on iPhones and Safari. You could try downloading Chrome and see if that works better.


#405

Chrome has the same behavior as Safari, because (fun fact) Apple requires all apps on the iPhone to use the Safari WebKit WKWebView to render webpages. ¯_(ツ)_/¯ Using “Chrome” on iOS just lets Google track you… it doesn’t actually change the rendering engine.


#406

I’m afraid there is nothing more I can do at this stage except just report it in the issue list for now … :frowning: