SuttaCentral Search Bugs 🪰

As of Feb of 2024, the search feature on SuttaCentral is still in active development. Please share any bugs or unexpected behaviour with the search in this thread.

There are a few other search related development threads:

And this is the GitHub project for all search related issues so if you are really keen you could see if it’s already reported: re-search · GitHub

Don’t hesitate to report problems. Even if it’s not an actual bug, it might help towards improvements.

5 Likes

OK, the volpage: search is kind of working again. I have started this issue to try and improve it.

When you say ‘kind of working again’, Bhante, how exactly does one enter in the search bar the reference data being searched for?

Great question.

To learn how, click on the “filter” icon:

(OK, so this isn’t actually a filter, sorry)

The very first thing shown is the volpage: feature:

It appears that everything after the volpage: and the citation gets ignored.

What is odd right now is that it seems to be returning every single occurance of any match to the volume and page, even if it isn’t in the right collection.

Give it a spin and please give feedback. Thanks!

When I search on SC I don’t see the same screen as you are showing , Bhante. I only see this:

So I don’t know where to go from here.

Ah, right. The screen shot I was showing was of the results page. Sc actually has two related but separate search features.

Your screen shot (I call) instant search. It instantly offers suggestions. It will accept filters, but the icon to show the filter help isn’t there. It’s difficult to work out where to put it because of mobile layout constraints.

So just do what you were doing and type moats, for example, and press enter or press the search icon.

This will take you to the results page. Then you will see the filter icon on the top right.

Ah, thank you.
That mostly works. That is, it did when I tried a few random volpages for mn, sn, and an. However, not for dn, which is odd.
I’ll play around with it a bit more.

1 Like

I was looking for a sutta where Nandaka teaches a tree-simile. So I tried Nandaka AND tree but this did not give any results neither did Nandako AND tree - I found the sutta another way, which is MN142 MN146. But it has Nandaka in it and tree, but no results?

1 Like

Perhaps they need to be in the same segment/sentence/paragraph for this to work?

It’s MN 146, I think.

If I search in:mn nandaka it’s the first result. The only actually, I just see different translations in different languages according to my language setting.

However, nandaka in:mn gives me nothing.

1 Like

Ah ok, I thought it would take the whole text.

Right, sorry, I have it open in a tab, but wrote down the wrong number. :wink:

1 Like

I don’t know. It was rather a question to Bhante @Snowbird .

In the Voice world, search results come always related to segments, that’s why I had this thought.

1 Like

No, absolutely not. The words can appear anywhere in the text.

You may have to clear your cache to see the new instructions for filters. (BTW, I don’t like this requirement and hopefully it will get changed so they can appear anywhere in the search string)

@Danny Can you share a screen shot of your Nandaka AND tree results? For me it is the third result:

Currently the full database search (which is what you see in the shot above) is not going to give results for that search because there is no fuzzy/typo allowance. However, in the “instant search” (AKA Algolia) you get the proper sutta as the only results:

So I need to see some screenshots to troubleshoot.

Thanks for telling us!

1 Like

Ah right, thanks! I usually just press enter, but I see now this a different search.

I tried it in incognito mode and it did work, probably some issue with clearing the cache.

I’d really love to see a screen shot if you are able. I don’t know why cache would have anything to do with this.

Are you sure you had English selected as a document language?

1 Like

Yes, I have English selected. The screenshot:

1 Like

Ah, it’s the match partial. If you untick that it should work.

This is absolutely a bug. @HongDa, any ideas? There is also this issue with partial matches. Not sure if it is related. Just searching nandaka with match partial works. So perhaps it is something to do with the AND

Thanks so much for sharing the screen shot.

2 Likes

Thanks! Yes, now it works! :+1:

I have no idea what ‘Match partial’ is for or how it works, so maybe also a bit more info what it does within the interface?

1 Like

Ooh. That’s great feedback. If it was working, it means that you could search nandak AND tree and then it would return both nandaka and nandako. It would also do tree and trees. I think eventually singulars/plurals will be built in automatically, though.

It is especially important for Pali. The reason searches aren’t always match partial is that some short words are ubiquitous as parts of other words. E.g. “cat” is everywhere in both Pali and English.

2 Likes

Thanks @Danny @Snowbird
Let me check!

2 Likes

I just noticed that the search results in pali do not show any diacritics. I wonder if that can be changed to show the correct text with diacritics:

3 Likes